Important: These forums are for discussions between SkyDemon users. They are not routinely monitored by SkyDemon staff so any urgent issues should be sent directly to our Customer Support.

SkyDemon freezes or crashes when connected to WiFi


Author
Message
ZorgroZ
ZorgroZ
Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)
Group: Forum Members
Posts: 13, Visits: 31
SkyDemon locks up periodically (or even crashes) when my device is connected to one of the on-board Wi-Fi networks of my plane:
* Stratux (versions 1.5b1 and 1.5b2)
* iLevil AHRS Mini

After a few seconds, SkyDemon becomes unresponsive or crashes. This happens regardless whether in planning or navigation mode (doesn't matter if I have third-party device enabled in settings or not).

SkyDemon is able to connect to my Stratux and receive GPS position and traffic, but alas only for a few seconds before it locks up or crashes.

I have tried SkyDemon on Android on the following devices: Moto G5 Plus, Amazon Kindle HD Fire 8 and 10. I have tried different recent SkyDemon versions (latest stable 3.11.2, and beta 3.11.3.26929). I have tried different SkyDemon settings, and cleared the application cache of SkyDemon.

SkyDemon does not have this issue when the device is connected to a regular wifi of my home. So I'm suspecting that the messages that those wifi devices are sending (GDL90, NMEA) are throwing off SkyDemon for some reason.

Do you have any ideas what could cause this, and how I can further diagnose the issue?

MarkusM
M
Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)
Group: Forum Members
Posts: 58, Visits: 55
It is a known bug in the Stratux Beta, stay at the latest Stratux v1.4r5 for now when using Skydemon!
ZorgroZ
ZorgroZ
Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)
Group: Forum Members
Posts: 13, Visits: 31
MarkusM - 2/19/2019 11:39:59 AM
It is a known bug in the Stratux Beta, stay at the latest Stratux v1.4r5 for now when using Skydemon!

Thanks Markus, I'll test it tonight.

Do you know what the specific issue is with Stratux release 1.5b1, or can you point me to a ticket on this?

MarkusM
M
Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)Too Much Forum (85 reputation)
Group: Forum Members
Posts: 58, Visits: 55
ZorgroZ - 2/19/2019 12:20:23 PM
MarkusM - 2/19/2019 11:39:59 AM
It is a known bug in the Stratux Beta, stay at the latest Stratux v1.4r5 for now when using Skydemon!

Thanks Markus, I'll test it tonight.

Do you know what the specific issue is with Stratux release 1.5b1, or can you point me to a ticket on this?

I think is is only on the list of known issues so far, but not yet a standalone ticket on github - may never get one as it appears directly connected to other open issues.

Edited 2/19/2019 12:57:59 PM by MarkusM
ZorgroZ
ZorgroZ
Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)
Group: Forum Members
Posts: 13, Visits: 31
MarkusM - 2/19/2019 11:39:59 AM
It is a known bug in the Stratux Beta, stay at the latest Stratux v1.4r5 for now when using Skydemon!

Just tested it with Stratux release v1.4r5: same problem on two different Android devices. SkyDemon locks up on one device (Moto G5 Plus) immediately after loading, and crashes on the other one (latest Kindle Fire HD). SkyDemon latest beta version.

I'll try it on my old iPad tonight, and with the latest stable release of SkyDemon.

Any other ideas?

Edited 2/19/2019 1:00:59 PM by ZorgroZ
ZorgroZ
ZorgroZ
Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)Too Much Forum (967 reputation)
Group: Forum Members
Posts: 13, Visits: 31
ZorgroZ - 2/19/2019 12:58:55 PM
MarkusM - 2/19/2019 11:39:59 AM
It is a known bug in the Stratux Beta, stay at the latest Stratux v1.4r5 for now when using Skydemon!

Just tested it with Stratux release v1.4r5: same problem on two different Android devices. SkyDemon locks up on one device (Moto G5 Plus) immediately after loading, and crashes on the other one (latest Kindle Fire HD). SkyDemon latest beta version.

I'll try it on my old iPad tonight, and with the latest stable release of SkyDemon.

Any other ideas?

I've tested with an old 9.7 inch iPad and SkyDemon 3.11.2. No freezes or crashes.

So this issue seems specific to SkyDemon on Android.

How could I diagnose further? Does SkyDemon have a log file or debugging mode which I could enable?

neubamat
n
Too Much Forum (342 reputation)Too Much Forum (342 reputation)Too Much Forum (342 reputation)Too Much Forum (342 reputation)Too Much Forum (342 reputation)Too Much Forum (342 reputation)Too Much Forum (342 reputation)Too Much Forum (342 reputation)Too Much Forum (342 reputation)
Group: Forum Members
Posts: 19, Visits: 18
This happens to me with SD 3.12.4.27411 on Fire Tab HD 8 as well.
I wasn't able to reproduce it with my Nokia 6 (Android P) even if just wifi was enabled (mobile data offline).
If I connect to a non routable wifi network, I'm getting a network connection error notification on Nokia 6 and no dialog but a lock up on HD 8.
That's my workaround:
  1. connect tab to wifi with internet connectivity and "Internet Usage" set so "Live Data when Planning" to download recent data.
  2. set SD to "Offline Mode", exit SD
  3. connect to stratux
  4. launch SD
I didn't see any crashes when following this procedure.


b3nn0
b
Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)
Group: Forum Members
Posts: 13, Visits: 0
Seeing the same issue. But I'm pretty sure that this is not a stratux bug. It also happens with other devices (as OP said, iLevil. And - no matter what stratux does, crashing is certainly not the right way to deal with it).
And yes, it is clearly related to network usage by skydemon. Somehow Skydemon seems to block the main thread while waiting for network i/o (until it times out eventually). This is definitely a skydemon issue. Also, it seems to be a rather new issue. I think I didn't have that problem in older Skydemon versions.
Basically, whenever the Android devices is connected to a Wifi without internet connection and Skydemon is set to use data, it will freeze occasionally.



b3nn0
b
Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)Junior Member (19 reputation)
Group: Forum Members
Posts: 13, Visits: 0
Sorry for the double post - any official news on this? It is really quite annoying..
I have used the report functionality of the "App not responding" dialog - no idea if it helps.
(EDIT: I'm a full-time Android developer, even though Java, not C#. If I can do anything to help, let me know)


Edited 4/30/2019 1:39:14 PM by b3nn0
Tim Dawson
Tim Dawson
SkyDemon Team (494K reputation)SkyDemon Team (494K reputation)SkyDemon Team (494K reputation)SkyDemon Team (494K reputation)SkyDemon Team (494K reputation)SkyDemon Team (494K reputation)SkyDemon Team (494K reputation)SkyDemon Team (494K reputation)SkyDemon Team (494K reputation)
Group: Moderators
Posts: 6K, Visits: 4.6K
You might like to contact our technical support about this. I have no knowledge of it but I do know we haven't changed our network connectivity on Android lately.
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search