Important: These forums are for discussions between SkyDemon users. They are not routinely monitored by SkyDemon staff so any urgent issues should be sent directly to our Customer Support.

Losing connection with switching apps in iOS (Read 2 times)


Author
Message
marioair
m
Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)
Group: Forum Members
Posts: 49, Visits: 0
I was wondering if you can help - I'm being bounced between various people to find the answer!

I have SD using PilotAware as GPS source all running on Ipad Mini ios12

If i minimise skydemon (switch apps or go to home screen) after about 5 mins (reproducible consistently and even at home when not flying) it will lose the GPS/Wifi from PaW. It comes up with the "no signal received for some time..." message

I'm pretty sure its a PaW problem, as when i use the IPAD internal GPS and switch SD to background, SD still works fine, so I think its something to do with the wifi connection to PaW. Is there any logging in SD i can get it to prove if this is the case? 

MarkusM
M
Too Much Forum (137 reputation)Too Much Forum (137 reputation)Too Much Forum (137 reputation)Too Much Forum (137 reputation)Too Much Forum (137 reputation)Too Much Forum (137 reputation)Too Much Forum (137 reputation)Too Much Forum (137 reputation)Too Much Forum (137 reputation)
Group: Forum Members
Posts: 96, Visits: 79
AFAIAC this is a combination of a known bug in the pilotaware DIY thing and Skydemon not being tolerant to connection issues. You can pull the usual log from you computer you synchronize the device with, but it won‘t help you much as long as you are a programmer of one of the parties involved?
marioair
m
Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)
Group: Forum Members
Posts: 49, Visits: 0
Which known issue with SkyDemon and which known issue PaW

The logs may not help me but I assume they’d help SD support!!!!!
Edited 6/20/2019 6:25:36 PM by marioair
PaulSS
P
Too Much Forum (575 reputation)Too Much Forum (575 reputation)Too Much Forum (575 reputation)Too Much Forum (575 reputation)Too Much Forum (575 reputation)Too Much Forum (575 reputation)Too Much Forum (575 reputation)Too Much Forum (575 reputation)Too Much Forum (575 reputation)
Group: Forum Members
Posts: 33, Visits: 1.4K
"AFAIAC this is a combination of a known bug in the pilotaware DIY thing"

Just transmitting again Markus or do you have any tangible information about this 'known bug'? I've never heard about it, so it'll be interesting to hear the details.

marioair
m
Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)
Group: Forum Members
Posts: 49, Visits: 0
There’s a setting in IOS called “Background App Refresh” which looks like it should “solve” the issues but SD doesn’t shown up as an app you can select for it in the settings pages.

I notice and android user apps reported the same issue

http://forums.skydemon.aero/Topic26915.aspx


marioair
m
Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)
Group: Forum Members
Posts: 49, Visits: 0
Do Support Team comment on here? I’ve had a couple of emails direct from SD support but not heard back. This dies at the worst possible times if you’re flying IFR!

Other users also reporting the problem
http://forum.pilotaware.com/index.php/topic,1625.0.html
TimT
T
Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)
Group: Forum Members
Posts: 49, Visits: 60
I have exactly the same problem. As marioair said, it is not only annoying but can affect safety. I reported it on 3 June 2019 to SD Support:
I found the WiFi link from PAW to the iOS device running Skydemon rather unstable. When I switch off the iOS device [or sometimes even when I only switch between apps], the WiFi link gets lost, Skydemon returns to Planning Mode, and my flight is “interrupted”; I need to “go fly” again, and reconnect to PAW.

At the time, the answer from SD Support was:
... the [WiFi] connection between the iPad and PilotAware ... is a little different .... It’s not a common problem that has been reported by other users (the connection is generally stable while the app is open), but I have noted it for future reference, and we’ll keep an eye on it.

I am by no means a W-Fi expert. However, in my experience it is NOT a common property of a WiFi link to ‘drop’ when an app is closed or sent to background. For example look at Google Maps that in all generality does not have off-line maps, but loads the background map in real time as the vehicle moves.

I'd say that Google Maps can very well:

- run in the background;
- still constantly refresh, via WiFi link to the Internet, the background map while the vehicle is moving;
- and – without any delay, certainly without the need to re-start the current route or anything – display the current position and the current background map the moment Google Maps is called to the foreground again.

Losing your position in SkyDemon, and the need to go through several clicks to restart (“go fly”) again, is not only inconvenient but also can impair your situational awareness in critical phases of the flight.

Edited 6/22/2019 7:47:51 AM by TimT
marioair
m
Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)Too Much Forum (630 reputation)
Group: Forum Members
Posts: 49, Visits: 0
For me it’s even more important now I have it hooked up for traffic alerts!

Still waiting for a response from SD support

Would be very interesting on IOS to see what “background app refresh” is and why SD doesn’t show up as an app that supports it.
TimT
T
Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)Too Much Forum (751 reputation)
Group: Forum Members
Posts: 49, Visits: 60
I confirm that SD doesn't appear in the list of apps where you can select "background app refresh" (in iOS Settings).

I did however some more testing today, and can reconfirm the loss of GPS data connection (and subsequent reverting to planning mode) when locking the iPad (using the hardware button on the fame of the iPad).

- When locking the device (using the hardware button on the frame of the iPad), it will *immediately* lose connection (even if only locked for only 5 sec).
- When I open again the iPad, SD is “Looking for GPS Data” for a few seconds, then reverts to planning mode and displays an error msg (“…no GPS data received for some time…”).
- However, GPS data *is* available, and SD can immediate be put back into “Go Flying” mode. The green banner “looking for GPS data” appears for a fraction of a second, and it will reliably re-connect to PAW.

I can no longer reproduce the same problem just by toggling between apps, even is SD is in the background for > 5 min. 

--

PAW Support reckons that this needs to be fixed on SD's side.


leemoore1966
leemoore1966
Too Much Forum (1.5K reputation)Too Much Forum (1.5K reputation)Too Much Forum (1.5K reputation)Too Much Forum (1.5K reputation)Too Much Forum (1.5K reputation)Too Much Forum (1.5K reputation)Too Much Forum (1.5K reputation)Too Much Forum (1.5K reputation)Too Much Forum (1.5K reputation)
Group: Forum Members
Posts: 22, Visits: 38

TimT - 6/22/2019 4:21:46 PM
PAW Support reckons that this needs to be fixed on SD's side.

Hi TimT (and TimD)
I don't think there is anything that can be done on our side - this may be a 'feature' of iOS that the Apps are put to sleep when the iPad is locked, and hence the timer in SD stops listening after not receiving data for some period
thx
Lee


GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search