SkyDemon


Samsung Galaxy S8


Samsung Galaxy S8

Author
Message
Flying spanner
Too Much Forum
Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)

Group: Forum Members
Posts: 7, Visits: 2
Just upgraded from a Samsung Galaxy S6 edge to the new S8 and noticed some layout problems. Love using SD on the S6, never any problems.
On the S8 The SD orb is too big meaning I can only display 4 instruments at the top of the screen in portrait and the top one is always obscured by the orb in landscape.
When viewing a saved log in the map I can't close it again because the red X in the bottom left of the virtual radar is only partially displayed in portrait, if I switch to landscape I can then click the X but the virtual radar formatting is wrong, it is squashed upwards and to the left.
Also if I try to view a log in Google Earth, the earth app opens but no log / trace is shown in it.
I don't know if these problems are due to the non standard screen size on the S8 or maybe because it's on android 7.0? I have mirrored my settings from the S6 where possible (android 6) and tried all combinations of screen zoom / font options in the phone settings.
I have tried the beta versions 3.8 & 3.81, both seem the same.
Anyone else seeing similar problems?

Tim Dawson
SkyDemon Team
SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)

Group: Moderators
Posts: 5.1K, Visits: 3.6K
We're not familiar with that particular device so it's hard for us to comment. Some screenshots might help, or some information as to whether there is something strange about the device's setup. Certainly the issue with Google Earth wouldn't be anything to do with SkyDemon.
Flying spanner
Too Much Forum
Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)

Group: Forum Members
Posts: 7, Visits: 2
Tim Dawson - 5/15/2017 3:08:49 PM
We're not familiar with that particular device so it's hard for us to comment. Some screenshots might help, or some information as to whether there is something strange about the device's setup. Certainly the issue with Google Earth wouldn't be anything to do with SkyDemon.

Thanks Tim.
S‌ome screenshots below.
http://forums.skydemon.aero/Uploads/Images/ea317002-6cb6-48d0-90c7-dda2.png" data-download-url="
Flying spanner
Too Much Forum
Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)

Group: Forum Members
Posts: 7, Visits: 2
Available screen resolutions on the phone are
1480x720. 2220x1080 and 2960x1440
It doesn't seem to make any difference which one I select.
Tim Dawson
SkyDemon Team
SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)

Group: Moderators
Posts: 5.1K, Visits: 3.6K
That all looks pretty normal. Nothing appears outsized, it's just that somebody has selected more instruments than there is space to display on that size of device. Hide a couple of instruments and it will look less cluttered.
Flying spanner
Too Much Forum
Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)Too Much Forum (101 reputation)

Group: Forum Members
Posts: 7, Visits: 2
Thanks Tim,
B‌ut how about the X to close the log and the virtual radar display in landscape mode? 
O‌n the S6 the orb is much smaller (approx 1/2 the size) when the instrument font is set to 1.0 see below.

Tim Dawson
SkyDemon Team
SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)SkyDemon Team (290K reputation)

Group: Moderators
Posts: 5.1K, Visits: 3.6K
I imagine there is just about enough room to display the orb in that situation, so it does its best to fit in the gap left (by shrinking). If there isn't any gap left, it may not be able to do that. Our options are limited when people tell us to display everything.
Constantinos
Forum Newbie
Forum Newbie (6 reputation)Forum Newbie (6 reputation)Forum Newbie (6 reputation)Forum Newbie (6 reputation)Forum Newbie (6 reputation)Forum Newbie (6 reputation)Forum Newbie (6 reputation)Forum Newbie (6 reputation)Forum Newbie (6 reputation)

Group: Forum Members
Posts: 1, Visits: 6
I notice the same on my Galaxy S7 (Model SM-G930F, Android 7.0).

I‌ suspect this has to do with Android's "Screen zoom" and "font size" settings (under the "Display" options) and Skydemon ignoring them when in landscape mode (?).

‌ Attached are three screenshots‌‌: In the first, I have just started up SD and entered simulation mode. In the second, I have clicked on the top area of the screen to display the PLOG. Pressing "back" from the PLOG, results in the third screenshot, with the fonts enlarged.

T‌his happens only in landscape mode. In fact, with the fonts already large as above, switching to portrait and then displaying the PLOG, will set the fonts back to normal upon hitting "back".

A‌nother bit of info: Before the PLOG is displayed, the screen often "flashes"‌ a few times (as if SD is quickly redrawing the screen a 2-3 times).

Hope this helps! BTW, Tim - and since this is my first post - thanks for a truly superb product!


‌‌‌
‌‌


GO
Merge Selected
Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...





Reading This Topic


Login
Existing Account
Username:


Password:


Select a Forum....







SkyDemon Forums


Search