Important: These forums are for discussions between SkyDemon users. They are not routinely monitored by SkyDemon staff so any urgent issues should be sent directly to our Customer Support.

Weight & Balance


Author
Message
mssmit
mssmit
Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)
Group: Forum Members
Posts: 4, Visits: 13
I notice that if country settings are set to "," as a decimal separator weight and balance coordinates of the envelope are messed up as the coordinates separator is also a "," I live in Holland and we use a "," (comma) as a decimal separator

This is entered initially:
205,669,205,720,410,980,564,980,564,669,205,669

This is how it looks like when I edit the W&B coordinates:
205,00,669,0, 205,00,720,0, 410,00,980,0, 564,00,980,0, 564,00,669,0, 205,00,669,0

This is how it looks like if I edit the data again:
205,00,0,0, 669,00,0,0, 205,00,0,0, 720,00,0,0, 410,00,0,0, 980,00,0,0, 564,00,0,0, 980,00,0,0, 564,00,0,0, 669,00,0,0, 205,00,0,0, 669,00,0,0

Looks like every item is converted to a decimal format (with 1 or 2 decimal places)

Am I doing something wrong or is this a bug ?

Skydemon Version 3.3.1.0
Edited 6/29/2015 2:24:25 PM by mssmit
Tim Dawson
Tim Dawson
SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)
Group: Forum Members
Posts: 6.5K, Visits: 5.2K
I don't suppose you're doing anything wrong, but we have full support for different decimal separators in SkyDemon so I've no idea why you're seeing that. We have thousands of European subscribers for whom this isn't a problem which is very puzzling.

Can anyone else (in Europe with a comma decimal separator) reproduce this?
mssmit
mssmit
Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)
Group: Forum Members
Posts: 4, Visits: 13
Did a simple check: if I set countrysettings to US (i.e. decimal separator "."(dot) ) than the problem does not appear.

So it definitely has to do with the comma as decimal separator

Maybe you (Tim) can try to reproduce this problem by setting your Windows country settings to Dutch
Edited 6/30/2015 12:30:20 PM by mssmit
Tim Dawson
Tim Dawson
SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)
Group: Forum Members
Posts: 6.5K, Visits: 5.2K
I've switched to Dutch. The settings I now get are:
0,39;318,0; 0,44;450,0; 0,45;450,0; 0,45;339,0

SkyDemon has switched to using a comma as a decimal separator and a semicolon as the separator between numbers.

Tim Dawson
Tim Dawson
SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)SkyDemon Team (552K reputation)
Group: Forum Members
Posts: 6.5K, Visits: 5.2K
Which locale, precisely, are you using?
mssmit
mssmit
Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)
Group: Forum Members
Posts: 4, Visits: 13
What do you mean with "locale"?
mssmit
mssmit
Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)Too Much Forum (619 reputation)
Group: Forum Members
Posts: 4, Visits: 13
Found locale but those settings are ok. 

The strange part is that on my laptop the problem does not occur (tested yesterday evening)

After checking if there were any differences between my laptop and my PC I found the problem:
on my PC the list separator was set to "," instead of ";"

All is running fine now.

Switching off :-))
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search