Important: These forums are for discussions between SkyDemon users. They are not routinely monitored by SkyDemon staff so any urgent issues should be sent directly to our Customer Support.

Nexus 7 warning and question


Author
Message
srayne
srayne
Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)
Group: Forum Members
Posts: 388, Visits: 8.3K
Andy,

I did a full reset after upgrading to 5.0 and having lots of lag and problems. Initially things were much better and then reverted to being bad again as apps were re-installed (I use most of them so needed to re-install them). SkyDemon (V3.2) continues to crash out and/or freeze when flying or simulating every 15 to 30 minutes but with no obvious cause.

However as apps are being updated to latest versions the problems are getting better slowly and the Nexus seems more responsive. I'm hoping that between Google and the app developers things will get slowly better.

I certainly don't have any evidence yet that the problems are caused (or even made worse) by SkyDemon itself it's just that SkyDemon is the only app that I use continuously for any significant length of time at one go.

Simon


adhawkins
adhawkins
Too Much Forum (25K reputation)Too Much Forum (25K reputation)Too Much Forum (25K reputation)Too Much Forum (25K reputation)Too Much Forum (25K reputation)Too Much Forum (25K reputation)Too Much Forum (25K reputation)Too Much Forum (25K reputation)Too Much Forum (25K reputation)
Group: Forum Members
Posts: 272, Visits: 2.1K
Simon, 

Just thought it was worth mentioning in case you weren't aware of it.

One habit I've got into is to always shutdown the tablet and restart it on the morning of my flight (the idea being all the junk apps that build up are removed from memory and hopefully not restarted).

Have you tried the hack of setting the maximum background processes in the developer options? It needs to be done on each restart of the tablet, but did make quite a big difference in usability for me before I bit the bullet and did the full reset.

Andy


srayne
srayne
Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)Too Much Forum (41K reputation)
Group: Forum Members
Posts: 388, Visits: 8.3K
Andy,

Yes I've tried all of those as well as clearing the system cache. None of them have made much long term improvement. I read that Lollipop release for other devices (e.g. Nexus 6 & HTC) has been delayed - maybe a solution will be forthcoming from Google?

Simon
MikeTwoOne
MikeTwoOne
Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)
Group: Forum Members
Posts: 146, Visits: 2.1K
Hi,

Android 5.0.1 has been released to (some) Nexus 7 2013 Wifi since yesterday.
I made some tests and it does not change SkyDemon's performance : it remains quite laggy.

FYI, SD is the one and only tool I use with this issue. Looking at Xamarin's forums and bugtracker (Xamarin is the platform between SD and Android), it seems we'll perhaps have to wait for an update since Xamarin has been made more "Lollipop/art ready" just after SD 3.2.0 was released.
Edited 12/5/2014 7:33:25 AM by MikeTwoOne
JSAG
JSAG
Too Much Forum (1.8K reputation)Too Much Forum (1.8K reputation)Too Much Forum (1.8K reputation)Too Much Forum (1.8K reputation)Too Much Forum (1.8K reputation)Too Much Forum (1.8K reputation)Too Much Forum (1.8K reputation)Too Much Forum (1.8K reputation)Too Much Forum (1.8K reputation)
Group: Forum Members
Posts: 13, Visits: 242
Hi Tim

By using the Wakey app to keep SD on screen I was able to fly without SD going to blank screen. However having flown from Fairoaks to the coast without a problem SD froze in PLOG mode. Whatever part of the screen was touched made no difference. It stayed that way until the Nexus on off button was pressed. It subsequently froze in navigation screen mode and stayed frozen until switched off.

After the flight I was able to merge together the bread crumbs.

As I said in my original post this is using Nexus 7 2012 with lollipop.

I am so concerned that this is compromising my use of SD that I have just bought a Nexus 7 2013 with kit kat!? and will only put SD on it. Although I see from the above posts that 2013 has its problems too.

I will keep you informed next time I can flight test it.

Cheers
John


Tim Dawson
Tim Dawson
SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)
Group: Forum Members
Posts: 6.5K, Visits: 5.1K
I think Google have pulled the Lollipop update until such time as they can make it work.
MikeTwoOne
MikeTwoOne
Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)
Group: Forum Members
Posts: 146, Visits: 2.1K
I've noticed something interesting. It also happens to me (the screen timeout) when Skydemon shows the Distance/time information under the orb when flying (that bug where planning/navigation mode are mixed).

Is it possible that, in this case, Skydemon is not forcing screen on because it partly works as in the planning mode?

M
Sky Painter
Sky Painter
Too Much Forum (44K reputation)Too Much Forum (44K reputation)Too Much Forum (44K reputation)Too Much Forum (44K reputation)Too Much Forum (44K reputation)Too Much Forum (44K reputation)Too Much Forum (44K reputation)Too Much Forum (44K reputation)Too Much Forum (44K reputation)
Group: Forum Members
Posts: 543, Visits: 9.7K
Today, I have updated my Nexus to Android 5.0.1 which is presumably a revision of Lollipop, and although I have only been able to test in Simulation Mode, I have so far had no problems with the screen timing out. So for those of you having problems, this may be the answer.

Mike
_________________________________________
Nexus 7 (2013) – Android 6.0.1 & SD 3.13.6.18418
Huawei P30 – Android 10.0.0 & SD 3.13.6.18418
PC – Windows 10 (Home Ed) Version 1909, Build 18363.815 & SD 3.13.6.0

MikeTwoOne
MikeTwoOne
Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)Too Much Forum (15K reputation)
Group: Forum Members
Posts: 146, Visits: 2.1K
I've spent some time testing / reproducing the issue and I confirm what I wrote before.

Using:
- SD 3.2.0
- Android 5.0.1
- Simulation mode

Everything is fine and no screen timeout happens UNLESS the bug with the distance/time under the orb occurs.
As soon as those pieces of information appear, timeout happens, depending on the system settings, as in planning mode. Which is somehow logical (and fully reproductible).

The only thing I'm not sure of is how to make time/distance appear. It seems to happen when the system is suffering from lag and tries to make up for lost time. Especially when a lot of warnings (terrain, areas, ...) are displayed (and not discarded). As if each warning popup was consuming way too much resources (rapid and certainly stupid shortcut from someone not knowing anything about SD internals).

Attached is a log file, with a zoom on this very specific moment.

Hope that helps,

M
Attachments
log1.txt (1K views, 21.00 KB)
Edited 12/10/2014 12:16:23 AM by MikeTwoOne
Tim Dawson
Tim Dawson
SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)SkyDemon Team (548K reputation)
Group: Forum Members
Posts: 6.5K, Visits: 5.1K
We actually fixed the distance/time showing issue a week or two ago, so perhaps if this issue is related that will be fixed too. I will try to get a beta published this week. A change of device orientation was what caused them to reappear.
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search