Important: These forums are for discussions between SkyDemon users. They are not routinely monitored by SkyDemon staff so any urgent issues should be sent directly to our Customer Support.

Sky DEmon & Proxy Servers


Author
Message
fbostic
fbostic
Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)
Group: Forum Members
Posts: 3, Visits: 8
Hi All,

maybe I am not the first one putting this on the table.

I have huge problems dealing with Sky Demon (full client, v. 3.0.5.0) behind a corporate firewall/proxy, which prevents, in order:

- maps downloading on first startup;

- maps updates;

- METAR/TAF download

- Cloud data retrieval...

The usual error is 407 - Proxy Authentication required.

I can't see a way to tell SD to use my corporate proxy, nor letting me kick in my corp credentials to get to the Internet. Angry

Using the web version is the alternative, but many tasks are definitely better with the "full" client, which I can use on a desktop with double monitor for an awesome planning experience... Cool

Thanks in advance for any advice!

Francesco
Tags
Edited 3/31/2014 6:25:04 PM by fbostic
Tim Dawson
Tim Dawson
SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)
Group: Moderators
Posts: 6.1K, Visits: 4.7K
The proxy server options are in the Setup -> Planning Options window.
fbostic
fbostic
Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)
Group: Forum Members
Posts: 3, Visits: 8
Thanks Tim, I found the sub-sub menu after digging the Forum, but... still no chance.

I can't hassle my IT folks to trace down which ports/protocols SD wants to use to get to the Internet, so having a piece of advice regarding what to explicitly open proxy-side would be a plus.

Maybe is trying to use different TCP ports other than the standard 80/443? Or it downloads via (S)FTP or otherwise?

Our corporate security system is rather narrow about that... Having a punctual port/protocol opening would not be difficult, but I'd love to know WHICH one...

Thanks in advance,

Francesco
Tags
Tim Dawson
Tim Dawson
SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)SkyDemon Team (513K reputation)
Group: Moderators
Posts: 6.1K, Visits: 4.7K
SkyDemon only uses standard HTTP over port 80. There is nothing special about its communications.
fbostic
fbostic
Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)Too Much Forum (524 reputation)
Group: Forum Members
Posts: 3, Visits: 8
Solved!

I had to set the proxy settings also with the port used internally by my corp network proxies (not 80, but 8080 in the case).

Thus, supplying the proxy address in the form IPAddr:port (e.g. 192.168.200.1:8080) made the trick.

Thanks for your help!

Francesco
Tags
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search