SkyDemon Forums

AIP Download hanging

By brinzlee - 10/8/2018 11:36:42 AM

Tim Dawson - 10/8/2018 11:18:41 AM
If it hangs on the same file, try downloading that file individually (by viewing it) to see if you get a more helpful error message.

Please do not clear your cache if all you want to do is download the latest files. It's hugely wasteful.

Thanks for the reply Tim....I have tried downloading the offending ones individually but they take forever and lock the iPad up, there is no associated error messages with them. There are too many that have not downloaded to do it individually....Some of the files are very big....the whole file is over 2GB in size.....I have left it to download many times now and it just crashes out after many hours trying.....the larger files being the problem.....I never used to have this problem doing a cache clear and download before....Something's changed !!
By Tim Dawson - 10/9/2018 11:20:20 AM

Not at our end, I'm afraid.
By easytherm - 11/12/2018 3:43:53 PM


Same problem here in Ipad mini 4 with ios 12.1
Switzerland AIP for example (about 150 Meg:  between 4 and 5 hours)
It does not hang but lasts forever.

By Tim Dawson - 11/13/2018 4:10:04 PM

The latest beta of SkyDemon for iOS fixes this issue. You can sign up for the beta from the beta page on our website, or you can await the next public version (next week at the latest).
By brinzlee - 10/5/2018 8:01:02 PM

Lastest version of SkyDemon and iOS 12 on an iPad Air 2
Cleared the cache to download the latest AIP for the UK, France, Germany
And it keeps hanging no matter which country I try and download. It’s starts off ok then hangs on the larger files..I have to stop SD as the cancel download button doesn’t work either. Have tried a reboot of my device but nothing gives. Any ideas
By Fleagle - 11/8/2018 12:51:05 PM

I had a similar  problem earlier in the year. I could down load any country except the UK just fine.  UK would just hang. I even reset and rebuilt my iPad but still no joy.

I reset my home router to factory setting - but still no luck

in the end I noted that if I disabled my routers firewall, I could then down load UK.

I have no idea why other countries would load but for some reason my firewall blocked UK - its not as if I had any personal rules in the firewall - it was just factory standard stuff
By Skyboy999 - 11/8/2018 5:06:14 PM

Update on this after reading similar thread in Charts forum- if I download files individually, it works but if I use the 'download all' little arrow, it hangs on large files.
By Skyboy999 - 11/7/2018 6:58:09 AM

I am also experiencing this albeit on different kit so believe there could be a problem at SD end.

The problem appears when I attempt to download AIP on my iPhone 6s running IOS 11.4 and I believe was fine before I updated SD to 3.10.5 end October. IOS hasn't been updated for a long long time, only SD.

I have no problem whatsoever downloading to my iPad Mini 4 running IOS 10.3,1

Hopefully, this will provide some more info for investigation and resolution.